What causes this? Stator issue

Discussion in 'Tech' started by assjuice cyrus, Sep 23, 2022.

  1. assjuice cyrus

    assjuice cyrus Well-Known Member

    What cause this? The stator trigger keeps Melting. This is the second one. Took this one out in 10 laps.
     

    Attached Files:

  2. metricdevilmoto

    metricdevilmoto Just forking around

    Check the rectifier.
     
    mpusch likes this.
  3. ducnut

    ducnut Well-Known Member

    The R/R is usually what smokes the stator.

    Not sure what that is in, but, I’ve put Roadstercycle SH847 Kits in two of my bikes. The SH847 is a Series R/R, which opens and closes the charging circuit, as needed. This allows for the stator to run MUCH cooler. Plus, the kit creates a standalone charging circuit, which is very beneficial on some bikes.
     
  4. ibidu1

    ibidu1 Well-Known Member

    I would also examine the flywheel, ive had the stator break off and explode internally. Some odd reason suzuki oem flywheel and oem stator made contact. But you really gotta just go through the harness and check the plugs, and inside terminals.
     
  5. thunderalley3

    thunderalley3 Well-Known Member

    Make sure you R/R has a good ground. I have gone to the extent of running a redundant ground wire before as a poor ground can wreak havoc. Also make sure that you are getting airflow over the R/R, bodywork sometimes changes the airflow. Also make sure the wires from the R/R are not grounded somewhere between the stator and R/R. I have seen the wires from the stator crushed together at the clamp by the stator cause this issue before.

    Just throwing things out there but have you increased the rev limiter a bunch?
     

Share This Page